Wifi to slow

Resolved

Resolved
Posted Nov 08, 2016 - 16:37 CET

Investigating

We are currently investigating this issue.
Posted Nov 08, 2016 - 11:26 CET